SafetyCulture & SafetyCulture Care Marketing Sites are unavailable
Incident Report for SafetyCulture
Resolved
This incident has been resolved.
Posted Nov 06, 2024 - 22:19 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 21:18 UTC
Investigating
We are currently experiencing issues with accessing the SafetyCulture and SafetyCulture Care Marketing websites. The SafetyCulture app is unaffected, and users may continue logging in using the web app (app.safetyculture.com) or mobile apps.
Posted Nov 06, 2024 - 20:29 UTC
This incident affected: SafetyCulture (Website).